Gechologic Support Forum

ESP32 Development (Glo and Gecho v2) => Hardware Questions => Topic started by: julian on October 02, 2019, 05:36:08 PM

Title: Using USB serial port
Post by: julian on October 02, 2019, 05:36:08 PM
I managed to build my Gecho Loopsynth kit OK, I'm enjoying playing with it and most things seem to be working but I haven't yet been able to get anything to come out of the USB serial port.

1) It seems like you have to remove batteries (I'm not using the rechargeable batter), switch the device on and then connect up the USB.  If I don't do this it goes into a mode where just the RST light is on (no RDY blink).

2) After powering it up by plugging in USB the RDY light is flashing.  I then start up my terminal emulator (I've tried PuTTY and TeraTerm).  When I open the COM port (in my case COM3) the RDY light stops flashing.  When I exit the terminal program it starts flashing again.  The device is not responding while RDY is not flashing so commands which should print on the serial port are not working.

3) The serial port is set to 115200 N81, is this correct? I have tried other settings without success.
Title: Re: Using USB serial port
Post by: mario on October 02, 2019, 08:03:16 PM
Hi Julian,

1) No need to remove batteries, just power it on before plugging in the USB. It can be plugged and unplugged at any time without affecting normal operation or playing, unless it is a PC which may cause HW reset (I guess this depends on OS and drivers).

2) Looks like your console is set to use RTS/CTS flow control? In Gecho the RTS line is used for HW reset, it is useful when flashing the firmware. Try to disable that in the settings - for example in PuTTY it's the "None (DTR/RTS disable)" option.

3) These settings look good (assuming it is no parity, 8 data bits, 1 stop bit).

Title: Re: Using USB serial port
Post by: julian on October 05, 2019, 12:51:09 PM
Hi Mario,

Thanks for your help.  I got it working using gtkterm on my Linux box.  That allows me to control the RTS line, I think the driver on Windows was asserting RTS even if RTS/CTS was disabled.

Title: Re: Using USB serial port
Post by: mario on November 30, 2019, 03:29:15 PM
Adding an example of how the settings should look like in PuTTY.

If your version for some reason does not have these two separate options for "Flow control = none", try to download ExtraPuTTY (