Author Topic: Firmware not updating from 0.223  (Read 37 times)

alefoot

  • Newbie
  • *
  • Posts: 9
    • View Profile
Firmware not updating from 0.223
« on: November 27, 2017, 08:58:37 AM »
Windows 10
Gecho App v0.61b
Clicking the 'check for updates' option then checking for available firmware returns a message to the effect that current firmware is 0.223 and that an update to v5.0 is available.
Update process appears to run [clearing memory and writing several sectors of data, handshake LED activity as previously seen]
After 'update' checking for available updates shows that Gecho still has firmware v0.223 installed.
Repeating process appears to give identical result.

Channel 112233 reports 223

Or so it appears here.
If I can give any further info please let me know, thanks!
« Last Edit: November 27, 2017, 09:53:08 AM by alefoot »

mario

  • Administrator
  • Jr. Member
  • *****
  • Posts: 52
    • View Profile
Re: Firmware not updating from 0.223
« Reply #1 on: November 28, 2017, 12:37:08 AM »
Thanks for the heads up! Might be caused by recently switching the website to a different type of server (to support https certificates for secure payments via Stripe)... The update scripts haven't been touched in a while so not sure where that "5" comes from, unless it is a wrongly decoded "number of chars" value preceding "0.223" (which is still most recent version). Glad to hear it didn't brick your Gecho - perhaps it just re-flashed it with a previously downloaded binary. Investigating, should be fixed soon. Cheers :)

mario

  • Administrator
  • Jr. Member
  • *****
  • Posts: 52
    • View Profile
Re: Firmware not updating from 0.223
« Reply #2 on: November 28, 2017, 09:44:53 AM »
ok, all is fixed now 8)